Blender News FORUMS Sensei Format Help Disable automatic clipping depth change

This topic contains 2 replies, has 2 voices, and was last updated by  flowstate 3 months, 1 week ago.

  • Disable automatic clipping depth change
  • #18420

    flowstate
    Participant

    Hi,

    I’m using Blender in a pipeline with Unreal Editor. Because of their inherent scale differences (1cm/unit in UE, 1m/unit in Blender), I have to have my blender objects scaled by 100. Thus, the best 3d view clipping settings for me are

    Near: 1m
    Far: 1km

    I have this saved in my startup file, no issues. However, at some point in my workflow with Sensei Format, it gets changed to:

    Near: ~.5mm (don’t really remember this number)
    Far: 7m

    And so my objects disappear. I just now realized that i could be watching the python console to find the commands, but even so:

    Is there any way for me to stop this automatic clipping depth change?

    Thanks,
    Eric

  • #18421
    Sensei
    Sensei
    Keymaster

    Hi. Yes. Auto view clipping is a Sensei Format feature which automatically adjusts view clipping when entering and exiting edit mode via the tab key. This generally produces the best of both worlds where you want to be able to expand your view as far as you can while in object mode dealing with various scene items (and not have things disappear in the background) but then not have a bunch of wire-frame lines lap over where they’re not supposed to when zooming in on things closely while working in edit mode.

    You can disable this option in the Builder menu (top left corner of toolshelf “T” in the 3D View) directly to the left of the Pocket feature. Uncheck “Auto View Clipping”. Then make sure you go to File > Save Startup File > and press “Ok” (you’ll want to do this directly after opening a new file so you don’t save something weird in your startup file).

  • #18432

    flowstate
    Participant

    Ah, okay thanks! I wish there was a way to go back in time and make myself watch those first few videos all the way through.

    WTFM, noob.

You must be logged in to reply to this topic.