Blender News FORUMS Materials/Textures Adding Texture Blender Castle Tutorial

This topic contains 2 replies, has 2 voices, and was last updated by  pachon22 2 years, 2 months ago.

  • Adding Texture Blender Castle Tutorial
  • #11499

    pachon22
    Participant

    Hello. I am Pedro. I am trying to complete this tutorial Blender Castle Part 3 (so far it is good) but when I try to add the texture I see everything black (The texture could be found in this same website:https://blendersensei.com/textures/grass-and-field/ ). I just upload also the Blender file with my model thanks.

    I hope that you can help me, i am trying to solve the problem for my own, but since I am new in blender it is kind of difficult. Well thanks for your answer have a good day.

    Attachments:
    1. Castle012.blend
  • #11501
    Sensei
    Sensei
    Keymaster

    Hi Pedro. A few things going on here:

    1. Your file seems to be in Cycles render mode (Blender has two main render engines “Blender Render” and “Cycles”). The tutorial from which this comes is rather old so in it the “Blender Render” render mode is being used. In the updated file I have switched the engine from “Cycles” to “Blender Render”.

    2. Your ground object (which you were trying to add the grass to) had no uv map. Typically a uv map is required to map images to textures. So you’ve got your object, your object has a material, the material has a texture, the texture has an image and to map the image to the object it needs a uv map. To create a uv map you can press Tab to enter edit mode press A to select all the mesh and press U to unwrap the object. There’s a whole lot to uv mapping things though, so you’ll have to do some more research on your own to learn how to better uv map things.

    3. You can include an image with the Blender file (like I did with the attachment) by pressing the little button next to the image file name (looks like a yellow-green box) under the “image” menu of the texture menu under where it says “source”. Click this for all the images you need to include in a file.

    4. Under the texture tab of the properties panel there is a menu called “Mapping”. Under where it says “Size:” you can increase the x and y values to make the image repeat so it’s not so huge and blown out. Only problem is,the texture you were using is not seamless so it looks pretty bad when it repeats. So I used an image from the Seamless Elemental Brush (sample) Pack you can download here on the site on the Store page. This image from this pack can repeat without seams. Though normally this image pack is used as brushes for sculpting and painting, it can also be used to texture objects like this.

    5. Also down where it says “Object Mode” in the 3D View, to the right of this are viewport shading options, make sure it’s set to “Material Viewport Shading”.

    • #11503

      pachon22
      Participant

      Thank you for your help and the free resources avaible. Thanks.

You must be logged in to reply to this topic.